Line separator

Device

Requirements

We would love to receive all types of used tablets and phones, but unfortunately, the latest video conferencing software does not support end of life device.   Please see our device requirements below:

Apple iPad / iPhone

  • iPhone 6 or newer

  • iPad Gen 3 or newer

  • Must be unlinked from your Apple ID and iCloud Account

  • Remove protective case

  • Must be reset to factory settings (Click here to learn how)

Android Phone / Tablet

  • Age : 4 years or newer

  • Must be unlinked from any management account

  • Remove protective case

  • Must be reset to factory settings (Click here to learn how)